aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-23 16:52:43 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-24 09:25:35 -0800
commit5af264c7b45d82c6d9cdabd1cde58e2b308d4031 (patch)
tree420c4a8eb01a10316ee8310b0a11e979c8b12008
parent46951201fca5900ce7dda38ba3c3913f786754ef (diff)
downloadmeta-openembedded-contrib-5af264c7b45d82c6d9cdabd1cde58e2b308d4031.tar.gz
spice: Use python3 and modules during build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index ebf4d576e5..9d3a0e6cb5 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -31,11 +31,10 @@ S = "${WORKDIR}/git"
inherit autotools gettext python3native python3-dir pkgconfig
-DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python-pyparsing-native python-six-native glib-2.0-native"
+DEPENDS += "spice-protocol jpeg pixman alsa-lib glib-2.0 python3-pyparsing-native python3-six-native glib-2.0-native"
DEPENDS_append_class-nativesdk = "nativesdk-openssl"
-export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
-export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
+export PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3"
CFLAGS_append = " -Wno-error"