aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuðni Már Gilbert <gudnimar@noxmedical.com>2024-04-23 06:38:12 +0000
committerKhem Raj <raj.khem@gmail.com>2024-04-23 15:18:30 -0700
commit0dba41b51f1d3aabbfc0c4c9f56215be20001f54 (patch)
tree8cc3346bcc77a6f4244d310698aa4f3e74e70011
parent900ef2731f2efd4cee9c5028392dcbbc74e2f812 (diff)
downloadmeta-openembedded-contrib-0dba41b51f1d3aabbfc0c4c9f56215be20001f54.tar.gz
python3-incremental: cleanup RDEPENDS and use python_setuptools_build_meta
Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb b/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
index 3d93cc05e9..503ef35a9e 100644
--- a/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
@@ -5,15 +5,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
SRC_URI[sha256sum] = "912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c24c0bd0"
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
RDEPENDS:${PN} += " \
- python3-twisted \
+ python3-twisted-core \
python3-click \
"
# -native is needed to build python[3]-twisted, however, we need to take steps to
# prevent a circular dependency. The build apparently does not use the part of
# python-incremental which uses python-twisted, so this hack is OK.
-RDEPENDS:python3-incremental-native:remove = "python3-twisted-native"
+RDEPENDS:python3-incremental-native:remove = "python3-twisted-core-native"
BBCLASSEXTEND = "native"