aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 22:05:08 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-13 07:17:03 -0800
commit0d4a59268cc696171534f6ddfbedc91a2b3abf1a (patch)
tree30b9530f2e09c15f5dde76ac8239b7e8ac0d39ea
parent0c6cdbe3dbe95ae1f4654c13583020ae55a6c0af (diff)
downloadmeta-openembedded-contrib-0d4a59268cc696171534f6ddfbedc91a2b3abf1a.tar.gz
nodejs: allow use of system gyp
Now that there is a gyp (python2) recipe in meta-python, allow its use instead of the bundled one for when meta-python is enabled. At the same time, unconditionally inherit pythonnative as in either case gyp actually uses python, and the build machine's python and installed modules should never be used. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index 4342693b34..e384b62869 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
DEPENDS = "openssl"
DEPENDS_append_class-target = " nodejs-native"
-inherit pkgconfig
+inherit pkgconfig pythonnative
COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
@@ -52,6 +52,7 @@ ARCHFLAGS ?= ""
PACKAGECONFIG ??= "ares icu libuv zlib"
PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
+PACKAGECONFIG[gyp] = ",,gyp-py2-native"
PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
PACKAGECONFIG[libuv] = "--shared-libuv,,libuv"
PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2"
@@ -77,6 +78,8 @@ python do_unpack() {
shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
if 'ares' in d.getVar('PACKAGECONFIG'):
shutil.rmtree(d.getVar('S') + '/deps/cares', True)
+ if 'gyp' in d.getVar('PACKAGECONFIG'):
+ shutil.rmtree(d.getVar('S') + '/tools/gyp', True)
if 'libuv' in d.getVar('PACKAGECONFIG'):
shutil.rmtree(d.getVar('S') + '/deps/uv', True)
if 'nghttp2' in d.getVar('PACKAGECONFIG'):