aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 22:05:07 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-13 07:17:03 -0800
commit0c6cdbe3dbe95ae1f4654c13583020ae55a6c0af (patch)
tree8a03d52e7f55e129acb7926269a23706e53b157b
parent08956bdd8962ca44eeea3772ea6be8061d1f5735 (diff)
downloadmeta-openembedded-contrib-0c6cdbe3dbe95ae1f4654c13583020ae55a6c0af.tar.gz
nodejs: delete all bundled deps in do_unpack() if needed
We can delete bundled deps where system-provided counterparts should be used instead. Amongst others, this ensures they are not used accidentally. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index 9af0d998c2..4342693b34 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -69,9 +69,24 @@ EXTRA_OEMAKE = "\
AR.host='${AR}' \
"
+python do_unpack() {
+ import shutil
+
+ bb.build.exec_func('base_do_unpack', d)
+
+ shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
+ if 'ares' in d.getVar('PACKAGECONFIG'):
+ shutil.rmtree(d.getVar('S') + '/deps/cares', True)
+ if 'libuv' in d.getVar('PACKAGECONFIG'):
+ shutil.rmtree(d.getVar('S') + '/deps/uv', True)
+ if 'nghttp2' in d.getVar('PACKAGECONFIG'):
+ shutil.rmtree(d.getVar('S') + '/deps/nghttp2', True)
+ if 'zlib' in d.getVar('PACKAGECONFIG'):
+ shutil.rmtree(d.getVar('S') + '/deps/zlib', True)
+}
+
# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
do_configure () {
- rm -rf ${S}/deps/openssl
export LD="${CXX}"
GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
# $TARGET_ARCH settings don't match --dest-cpu settings