summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-07-07 15:24:20 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-09 11:35:36 +0200
commitf7aff2a3a0c99564f34a528f124ae4e013a5a878 (patch)
tree2aa099490899875f5b7bb1835f3edac71a447c7a
parent6aa6fddea9927382d483c43db844e8619e1f949d (diff)
downloadmeta-openembedded-contrib-f7aff2a3a0c99564f34a528f124ae4e013a5a878.tar.gz
start-stop-daemon: Add version 1.16.0.2 (initial recipe)
Provides a stand-lone s-s-d that is extracted from dpkg of the corresponding version. * dpkg_1.16.0.2 is hostedd on sources.oe.org, since debian wipes old versions from their mirrors * Installing only s-s-d (binary) would be covered by automake rules. Documentation would be missing. Thus install all and purge non s-s-d files. Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
new file mode 100644
index 0000000000..9b1084aeb9
--- /dev/null
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Debian's start-stop-daemon utility extracted from the dpkg \
+package"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;md5=a963623e4588f70122865aaa7a370ce4"
+# start-stop-daemon is usually shipped by dpkg
+RCONFLICS_${PN} = "dpkg"
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2"
+SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a"
+SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
+
+inherit autotools gettext
+
+S = "${WORKDIR}/dpkg-${PV}"
+
+EXTRA_OECONF = " \
+ --with-start-stop-daemon \
+ --without-bz2 \
+ --without-deselect \
+ --without-install-info \
+ --without-selinux \
+ --without-update-alternatives \
+"
+
+do_install_append () {
+ # remove everything that is not related to start-stop-daemon, since there
+ # is no explicit rule for only installing ssd
+ find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
+ find ${D} -depth -type d -empty -exec rmdir {} \;
+}