aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-07-23 10:42:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:11:05 +0200
commitf0063b49e67008ff21177d26ad9d06394de8bba0 (patch)
treea3c750f19cbc5abf1f7eaaa7c54ae0fb3524dbb3
parente36e36b16e872d7883ea722fdc27f3d7a2f71e88 (diff)
downloadmeta-openembedded-contrib-f0063b49e67008ff21177d26ad9d06394de8bba0.tar.gz
xfce4-notifyd: update to 0.2.4
This update makes xfce4-notifyd compatible to oe-core's current libnotify and libnotify >= 0.7.0 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch152
-rw-r--r--meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb (renamed from meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb)10
2 files changed, 157 insertions, 5 deletions
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch b/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch
new file mode 100644
index 0000000000..9e61a0ecfd
--- /dev/null
+++ b/meta-xfce/recipes-apps/xfce4-notifyd/files/0001-Restore-libnotify-version-7.0.0-compatibility.patch
@@ -0,0 +1,152 @@
+From ebfbe9358068716ed7f39e253bce4d13e696bc9b Mon Sep 17 00:00:00 2001
+From: Ivailo Monev <xakepa10@gmail.com>
+Date: Wed, 11 Dec 2013 13:18:13 +0000
+Subject: [PATCH 1/1] Restore libnotify version < 7.0.0 compatibility
+
+Upstream-Status: Pending [1]
+
+[1] https://mail.xfce.org/pipermail/xfce/2013-December/032733.html
+
+Signed-off-by: Ivailo Monev <xakepa10@gmail.com>
+---
+ Makefile.am | 4 +++-
+ configure.ac | 2 +-
+ tests/test-actions.c | 7 ++++++-
+ tests/test-positioning.c | 7 ++++++-
+ tests/test-text.c | 21 ++++++++++++++++++---
+ xfce4-notifyd-config/main.c | 7 ++++++-
+ 6 files changed, 40 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index df81bea..034d6c1 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -271,9 +271,11 @@ noinst_PROGRAMS = \
+
+ tests_cflags = \
+ -I$(top_srcdir) \
+- $(LIBNOTIFY_CFLAGS)
++ $(LIBNOTIFY_CFLAGS) \
++ $(common_cflags)
+
+ tests_ldadd = \
++ $(common_ldadd) \
+ $(LIBNOTIFY_LIBS)
+
+ tests_test_actions_SOURCES = tests/test-actions.c
+diff --git a/configure.ac b/configure.ac
+index cf5258f..9d2e8a7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -67,7 +67,7 @@ XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [0.1.0svn-r26876])
+ XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0])
+ XDT_CHECK_PACKAGE([DBUS], [dbus-1], [1.0.0])
+ XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [0.72])
+-XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.7.0])
++XDT_CHECK_PACKAGE([LIBNOTIFY], [libnotify], [0.5.0])
+
+ AC_PATH_PROG([DBUS_BINDING_TOOL], [dbus-binding-tool])
+ AS_IF([test -z "$DBUS_BINDING_TOOL"],
+diff --git a/tests/test-actions.c b/tests/test-actions.c
+index a7f6494..4cdf882 100644
+--- a/tests/test-actions.c
++++ b/tests/test-actions.c
+@@ -106,7 +106,12 @@ int main (int argc, char **argv)
+
+ notification = notify_notification_new ("Action!",
+ "Click my shiny actions",
+- NULL);
++ NULL
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ notify_notification_add_action (notification,
+ "action1",
+diff --git a/tests/test-positioning.c b/tests/test-positioning.c
+index 4478a92..2a90c6e 100644
+--- a/tests/test-positioning.c
++++ b/tests/test-positioning.c
+@@ -60,7 +60,12 @@ int main (int argc, char **argv)
+
+ notification = notify_notification_new (summary,
+ body,
+- NULL);
++ NULL
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ if (!notify_notification_show (notification, NULL))
+ {
+diff --git a/tests/test-text.c b/tests/test-text.c
+index 7500cb2..ac95931 100644
+--- a/tests/test-text.c
++++ b/tests/test-text.c
+@@ -40,7 +40,12 @@ int main (int argc, char **argv)
+
+ notification = notify_notification_new ("Test text support",
+ "Does it work?",
+- NULL);
++ NULL
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ if (!notify_notification_show (notification, NULL))
+ {
+@@ -56,7 +61,12 @@ int main (int argc, char **argv)
+
+ notification = notify_notification_new ("Summary only support",
+ NULL,
+- NULL);
++ NULL
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ if (!notify_notification_show (notification, NULL))
+ {
+@@ -75,7 +85,12 @@ int main (int argc, char **argv)
+ "<b>Bold</b>\n"
+ "<u>Underlined</u>\n"
+ "<a href=\"http://www.xfce.org\">Xfce Web site</a>",
+- NULL);
++ NULL
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ if (!notify_notification_show (notification, NULL))
+ {
+diff --git a/xfce4-notifyd-config/main.c b/xfce4-notifyd-config/main.c
+index 5977749..eff4994 100644
+--- a/xfce4-notifyd-config/main.c
++++ b/xfce4-notifyd-config/main.c
+@@ -56,7 +56,12 @@ xfce_notifyd_config_show_notification_preview(GtkWindow *parent_window)
+ notification =
+ notify_notification_new(_("Notification Preview"),
+ _("This is how notifications will look like"),
+- "xfce4-notifyd");
++ "xfce4-notifyd"
++#if NOTIFY_CHECK_VERSION > (0, 6, 9)
++ );
++#else
++ ,NULL);
++#endif
+
+ notify_notification_add_action(notification,
+ "button",
+--
+1.9.3
+
diff --git a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb
index eb554ce0a9..9d0e19801e 100644
--- a/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.2.bb
+++ b/meta-xfce/recipes-apps/xfce4-notifyd/xfce4-notifyd_0.2.4.bb
@@ -2,11 +2,14 @@ SUMMARY = "Easily themable notification daemon with transparency effects"
HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "libxfce4util libxfce4ui xfconf gtk+ dbus dbus-glib"
-
+DEPENDS = "libxfce4util libxfce4ui xfconf gtk+ dbus dbus-glib libnotify"
inherit xfce-app
+SRC_URI[md5sum] = "094be6f29206aac8299f27084e284e88"
+SRC_URI[sha256sum] = "8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0"
+SRC_URI += "file://0001-Restore-libnotify-version-7.0.0-compatibility.patch"
+
do_compile_prepend() {
mkdir -p xfce4-notifyd
}
@@ -16,6 +19,3 @@ FILES_${PN} += " \
${datadir}/themes \
${datadir}/dbus-1 \
"
-
-SRC_URI[md5sum] = "8687fb7a0f270231ada265e363b6ffcc"
-SRC_URI[sha256sum] = "b66e68dfc2164bcf479acd3c7e8b6f83065d23aef988535e2db3506d06a39168"