aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-19 20:59:59 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-29 16:58:44 -0700
commitb02424812ede9ec095702734427f3f761d61452b (patch)
tree632b78bdb57f652a114381a4f652c3fbf0a41874
parentdbc5708539c24903569d8d648a763d2dd6b9db61 (diff)
downloadmeta-openembedded-contrib-b02424812ede9ec095702734427f3f761d61452b.tar.gz
libqb: Upgrade to 1.0.3
Drop upstreamed patch Backport another patch to fix out of tree build regression Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch43
-rw-r--r--meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch56
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.3.bb (renamed from meta-oe/recipes-extended/libqb/libqb_1.0.2.bb)6
3 files changed, 60 insertions, 45 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch b/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
deleted file mode 100644
index 28bc5c07df..0000000000
--- a/meta-oe/recipes-extended/libqb/libqb/0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From e6fbad0c122ba8e87b67a9e2447505adcaafe204 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 29 Mar 2017 16:31:38 -0700
-Subject: [PATCH] Remove runtime check for CLOCK_MONOTONIC
-
-Does not work during cross compile
-
-use a compile-time check to detect whether the
-monotonic clock is available. This check can run just fine when we are
-cross-compiling.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 12 ++++++++++--
- 1 file changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index fa13ae6..f4f0f46 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -175,9 +175,17 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- )
-
- AC_MSG_CHECKING(for a working clock_getres(CLOCK_MONOTONIC, &ts))
--AC_RUN_IFELSE([AC_LANG_PROGRAM(
-+AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[#include <time.h>]],
--[[struct timespec ts; if(clock_getres(CLOCK_MONOTONIC, &ts)) return -1;]])],
-+[[
-+#include <unistd.h>
-+int main() {
-+#if !(defined(_POSIX_MONOTONIC_CLOCK) && _POSIX_MONOTONIC_CLOCK >= 0 && defined(CLOCK_MONOTONIC))
-+ #error No monotonic clock
-+#endif
-+ return 0;
-+
-+]])],
- [
- AC_MSG_RESULT([yes])
- AC_DEFINE_UNQUOTED([HAVE_CLOCK_GETRES_MONOTONIC], 1, [Define to 1 if clock_getres(CLOCK_MONOTONIC, &ts) works])
---
-2.12.1
-
diff --git a/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch b/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
new file mode 100644
index 0000000000..c82f3bf017
--- /dev/null
+++ b/meta-oe/recipes-extended/libqb/libqb/0001-build-fix-configure-script-neglecting-re-enable-out-.patch
@@ -0,0 +1,56 @@
+From 73d2aea33e32272bac693550e8a3b0e3ad89707f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
+Date: Tue, 26 Dec 2017 00:02:26 +0100
+Subject: [PATCH] build: fix configure script neglecting, re-enable out-of-tree
+ builds
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+For the former, a prototype and the final code got (hm, mysteriously)
+intertwisted. For the latter, I am clearly guilty of (rare, anyway)
+testing of the out-of-tree builds only with libqb-already-system-wide
+scenario, which is rather shortsighted.
+
+Thanks Fabio and his ci.kronosnet.org project for spotting that.
+
+X-mas-present-for: Fabio M. Di Nitto <fdinitto@redhat.com>
+Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
+---
+Upstream-Status: Backport
+
+ configure.ac | 2 +-
+ lib/Makefile.am | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9900310..f9761cc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -710,7 +710,7 @@ if test "x${GCC}" = xyes; then
+ | grep __stop___verbose | cut -d" " -f 3)
+ test "${verbose_start_addr}" = "${verbose_stop_addr}" \
+ && gcc_has_attribute_section_visible=no \
+- || { verbose_start_type=$(${READELF} -s backup \
++ || { verbose_start_type=$(${READELF} -s "conftest${shrext_cmds}" \
+ | sed -n '/__start___verbose/{s/^\s*//p;q}' \
+ | tr -s ' ' \
+ | cut -d" " -f6)
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index 6ca6b15..b035f0b 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -101,7 +101,9 @@ endif
+ endif
+
+ qblog_script.ld: %.ld: %.ld.in
+- $(AM_V_GEN)$(CPP) -xc -I$(top_srcdir)/include -D_GNU_SOURCE -C -P $< \
++ $(AM_V_GEN)$(CPP) -C -D_GNU_SOURCE -P \
++ -I$(top_srcdir)/include -I$(top_builddir)/include \
++ -xc $< \
+ | sed -n "/$$(sed -n '/^[^#]/{s/[*\/]/\\&/g;p;q;}' $<)/,$$ p" \
+ > $@
+
+--
+2.16.2
+
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.2.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
index 574f6601ca..73cea5e398 100644
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.2.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
@@ -11,12 +11,14 @@ inherit autotools pkgconfig
PV .= "+git${SRCPV}"
-SRCREV = "608de6d59a3de0eef0fbcbd8f284acbc018daa9a"
+# v1.0.3
+SRCREV = "28dff090c74b6ba8609c4797294a5afe3fe73987"
SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
- file://0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch \
+ file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \
"
S = "${WORKDIR}/git"
+CFLAGS += "-pthread -D_REENTRANT"
do_configure_prepend() {
( cd ${S}
${S}/autogen.sh )