aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:24 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:35 -0800
commita32aeade02fe4618b8ecebe5a6e0fd63c4b8a359 (patch)
treeb6a46eb7f966072978f5045e303d22f7bc9a40a5
parentd3b75642db2bbf0685287a66148343007e17fffa (diff)
downloadmeta-openembedded-contrib-a32aeade02fe4618b8ecebe5a6e0fd63c4b8a359.tar.gz
python3-serpent: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Remove trailing whitespace Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.41.bb11
2 files changed, 7 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-serpent/run-ptest b/meta-python/recipes-devtools/python/python3-serpent/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-serpent/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-serpent/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.41.bb b/meta-python/recipes-devtools/python/python3-serpent_1.41.bb
index 480e3ab388..941b5ee0f3 100644
--- a/meta-python/recipes-devtools/python/python3-serpent_1.41.bb
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.41.bb
@@ -11,8 +11,9 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytz \
+ python3-pytest \
+ python3-pytz \
+ python3-unittest-automake-output \
"
do_install_ptest() {
@@ -21,6 +22,6 @@ do_install_ptest() {
}
RDEPENDS:${PN} += "\
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
-"
+ python3-netclient \
+ python3-numbers \
+"