aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:37 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:37 -0800
commit9c52cc5b3d615c35a5b9dc8e25766a689d21db9e (patch)
treeb067004617bb7860c89e1ae44bc1a3cb78f67c48
parentf75e988e64a4f56b344b5d9a953bad4943c04a51 (diff)
downloadmeta-openembedded-contrib-9c52cc5b3d615c35a5b9dc8e25766a689d21db9e.tar.gz
python3-cachetools: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools/run-ptest b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-cachetools/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb b/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
index 5946c267aa..22060ef049 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_5.3.2.bb
@@ -15,11 +15,12 @@ SRC_URI += " \
"
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-math \
+ python3-math \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {