aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:26 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:36 -0800
commit3f5af1db9a8038fdf7b435b2771359f9415c7d45 (patch)
tree1c6e3c5de199f3e526765944b1cf6184920a6752
parentba1539592a9e4224a784f8832b64b0c2473531ff (diff)
downloadmeta-openembedded-contrib-3f5af1db9a8038fdf7b435b2771359f9415c7d45.tar.gz
python3-requests-toolbelt: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Sort RDEPENDS for ptest alphabetically Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb13
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest b/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb b/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
index 2534c1c62c..9cbe4927a2 100644
--- a/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
@@ -14,15 +14,16 @@ SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c8
inherit pypi setuptools3 ptest
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-requests (>=2.0.1) \
+ python3-requests (>=2.0.1) \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-betamax \
- ${PYTHON_PN}-mock \
- ${PYTHON_PN}-multiprocessing \
- ${PYTHON_PN}-trustme \
+ python3-betamax \
+ python3-mock \
+ python3-multiprocessing \
+ python3-pytest \
+ python3-trustme \
+ python3-unittest-automake-output \
"
do_install_ptest() {