aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:35 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:37 -0800
commit23de36be41b607db156f67a2e7b47045e79de822 (patch)
tree7e6c0b05e8af77e7d22d349bd2e4d9b84705af89
parent0a982fba812243058a81a42d3e586b112376c17c (diff)
downloadmeta-openembedded-contrib-23de36be41b607db156f67a2e7b47045e79de822.tar.gz
python3-blinker: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb5
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb4
3 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-blinker/run-ptest b/meta-python/recipes-devtools/python/python3-blinker/run-ptest
index 15c3f6282d..69cd362f69 100644
--- a/meta-python/recipes-devtools/python/python3-blinker/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-blinker/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb b/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb
index f1d8b4fa95..8f2cf4883d 100644
--- a/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.7.0.bb
@@ -9,11 +9,12 @@ inherit pypi python_setuptools_build_meta ptest
SRC_URI += "file://run-ptest"
RDEPENDS:${PN} += "\
- ${PYTHON_PN}-asyncio \
+ python3-asyncio \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
index dbde8963e6..5c6f4e2356 100644
--- a/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.5.1.bb
@@ -13,8 +13,8 @@ SRC_URI +=" \
file://run-ptest \
"
-RDEPENDS:${PN}_ptest +=" \
- python3_pytest \
+RDEPENDS:${PN}-ptest +=" \
+ python3-pytest \
python3-unittest-automake-output \
"