aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:12 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:34 -0800
commit0ba05a291773487b5178caedfd9f010d680a5295 (patch)
tree66c6a0259f648d1400448b93da6615ca51ee744c
parent5f6e352b2711d7dab7209182b6dff2a9ff2b53c0 (diff)
downloadmeta-openembedded-contrib-0ba05a291773487b5178caedfd9f010d680a5295.tar.gz
python3-whoosh: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Sort RDEPENDS for ptest alphabetically Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb19
2 files changed, 11 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
index 3385d68939..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-whoosh/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index ed2a6d423f..38d3e1cecd 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -16,13 +16,13 @@ PYPI_PACKAGE_EXT = "zip"
inherit ptest pypi setuptools3
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-email \
- ${PYTHON_PN}-multiprocessing \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-pickle \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
+ python3-email \
+ python3-multiprocessing \
+ python3-netclient \
+ python3-numbers \
+ python3-pickle \
+ python3-shell \
+ python3-stringold \
"
SRC_URI += " \
@@ -30,8 +30,9 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-fcntl \
+ python3-fcntl \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {