aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2018-06-12 21:03:26 +0200
committerKhem Raj <raj.khem@gmail.com>2018-06-14 09:01:12 -0700
commit7ad706c61acae1ddd77c53f1708b0ea9b41fb4dd (patch)
tree587e4303be1d685667cefbe7f0d94b20a4ccc7c8
parenta752aefa9e3a033fc0e6374bfd701bc2f05e4de0 (diff)
downloadmeta-openembedded-contrib-7ad706c61acae1ddd77c53f1708b0ea9b41fb4dd.tar.gz
ne10: Use `cp -d ...` instead of `cp -a ...` to install a symbolic link
Using `cp -a ...` to install the link will preserv the owner of the original link, which will be the user who ran the do_compile task, rather than root. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 76e0741b1f..3afdff7786 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -38,7 +38,7 @@ do_install() {
install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/
install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/
install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/
- cp -a ${B}/modules/libNE10.so ${D}${libdir}/
+ cp -d ${B}/modules/libNE10.so ${D}${libdir}/
}
# ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel]