aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-24 00:00:25 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:35:24 -0800
commit8abf4f642a3bc4132bbe2808097a96c2c8b38b49 (patch)
tree30264617e5bf684c66d85a7278409496c1ad0c6c
parent2509f659e45d04abf295b50afe001c72f87113b6 (diff)
downloadmeta-openembedded-contrib-8abf4f642a3bc4132bbe2808097a96c2c8b38b49.tar.gz
netplan: Add knob to enable tests
this puts python3-nose away from default requirements, nose dependency should eventually be removed and perhaps converted to pytest Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan_0.104.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
index 6a32f55d47..e26649744c 100644
--- a/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
+++ b/meta-networking/recipes-connectivity/netplan/netplan_0.104.bb
@@ -22,7 +22,11 @@ SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined
DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
-RDEPENDS:${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid libnetplan"
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[tests] = ",,,python3-nose python3-coverage python3-netifaces python3-pycodestyle python3-pyflakes python3-pyyaml"
+
+RDEPENDS:${PN} = "python3 python3-core python3-netifaces python3-pyyaml util-linux-libuuid libnetplan"
inherit pkgconfig systemd