aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Alberto Lopez Perez <clopez@igalia.com>2023-10-17 23:24:54 +0100
committerKhem Raj <raj.khem@gmail.com>2023-10-17 21:42:56 -0700
commit8188ee344e425035387d4485b6a6457dd4da9424 (patch)
tree9126583ac4e0a95b4c2d9dbf0c9ba12b155605e0
parent2b4cb938b043c77f9f12f5cfb84fbc8f1f3fbf4d (diff)
downloadmeta-openembedded-contrib-8188ee344e425035387d4485b6a6457dd4da9424.tar.gz
libbacktrace: Update version and enable shared library.
* Update to the last version as of today. * Fix typo: EXTRA_OECONF * Enable building a shared library (.so) * Disable building a static library (.a) * Manually passing `-fPIC` is not longer needed because that flag is already enabled by autotools when building the shared library. * Enable the RISCV64 build-recause libunwind supports this archicture since OE-Core-rev: 2b2f6ff01efd Signed-off-by: Carlos Alberto Lopez Perez <clopez@igalia.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
index 609e55f4ac..46fa81866b 100644
--- a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
+++ b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
@@ -11,20 +11,17 @@ DEPENDS += "libunwind"
SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master"
PV = "1.0+git${SRCPV}"
-SRCREV = "4f57c999716847e45505b3df170150876b545088"
+SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613"
S = "${WORKDIR}/git"
inherit autotools
-EXTR_OECONF += "--with-system-libunwind"
-
-CFLAGS += "-fPIC"
+EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static"
do_configure() {
oe_runconf
}
-# libunwind does not support RISCV yet
-COMPATIBLE_HOST:riscv64 = "null"
+# libunwind does not support RISCV32 yet
COMPATIBLE_HOST:riscv32 = "null"