aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-17 09:10:15 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-27 15:38:22 +0200
commit49721325bededb18d95d1dfe9fafa1e8ecc76677 (patch)
treed4f4beb7651821a04c72d27a28e54a0162be6316
parent2318f8ee8be985a0e600fc457b8cc55d5aa9144f (diff)
downloadmeta-openembedded-contrib-49721325bededb18d95d1dfe9fafa1e8ecc76677.tar.gz
mg: stop relying on make -e
Relying on 'make -e' isn't ideal, as it's less implicit behavior, relies on variable exports, and hides the variables being used from someone reading the recipe. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/mg/mg_20110905.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/mg/mg_20110905.bb b/meta-oe/recipes-support/mg/mg_20110905.bb
index e924bbd4bb..95aeb62a3b 100644
--- a/meta-oe/recipes-support/mg/mg_20110905.bb
+++ b/meta-oe/recipes-support/mg/mg_20110905.bb
@@ -11,7 +11,17 @@ SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
SRC_URI[md5sum] = "2de35316fa8ebafe6003efaae70b723e"
SRC_URI[sha256sum] = "1cd37d7e6a3eecc890a5718c38b8f38495057ba93856762a756ccee2f9618229"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'LDFLAGS=${LDFLAGS}' \
+ \
+ 'prefix=${prefix}' \
+ 'bindir=${bindir}' \
+ 'libdir=${libdir}' \
+ 'includedir=${includedir}' \
+ 'mandir=${mandir}' \
+"
do_configure () {
sed -i Makefile.in -e 's,^prefix=.*,prefix=${prefix},'