aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-05 07:52:41 +0000
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit229a047d9d1fc9abccb6bc3ee2fcfb1f70ef5d8d (patch)
tree44550c00ebc244b1b532401bb6d098400ced6bc5
parent1163361b6a2daae73528848f8aa58dd644efde33 (diff)
downloadmeta-openembedded-contrib-229a047d9d1fc9abccb6bc3ee2fcfb1f70ef5d8d.tar.gz
spice: append to CFLAGS instead of +=
* so that -Wno-address-of-packed-member is used for all the builds not only for target builds * with native it was overwritten with BUILD_CFLAGS and for nativesdk with BUILDSDK_CFLAGS * this issue isn't specific for gcc-9 as the original commit said, I see nativesdk-spice failing on older hosts with gcc-7 with the same issue * also use -Wno-error=address-of-packed-member instead of -Wno-address-of-packed-member so that there is still a warning, just not fatal for the build in combination with -Werror. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 3c45d1f5e1..552f81df0a 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -37,7 +37,7 @@ DEPENDS_append_class-nativesdk = "nativesdk-openssl"
export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages"
-CFLAGS += "-Wno-address-of-packed-member"
+CFLAGS_append = " -Wno-error=address-of-packed-member"
PACKAGECONFIG_class-native = ""
PACKAGECONFIG_class-nativesdk = ""