aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-02-16 16:56:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2023-02-16 20:16:50 +0100
commitecab1bc3e5fa7b55221d8533ad4a1f629bf835b5 (patch)
tree671725aa446422367e6301b6a587a546fdb8aa2f
parentb117fc49e5a43a06fcf397f53023c18693975950 (diff)
downloadmeta-openembedded-contrib-ecab1bc3e5fa7b55221d8533ad4a1f629bf835b5.tar.gz
nodejs: remove redundant boolean to getVar
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
index b340a48218..4431edd6ca 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
@@ -93,17 +93,17 @@ python do_unpack() {
import shutil
bb.build.exec_func('base_do_unpack', d)
- shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
+ shutil.rmtree(d.getVar('S') + '/deps/openssl')
if 'ares' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/deps/cares', True)
+ shutil.rmtree(d.getVar('S') + '/deps/cares')
if 'brotli' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/deps/brotli', True)
+ shutil.rmtree(d.getVar('S') + '/deps/brotli')
if 'libuv' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/deps/uv', True)
+ shutil.rmtree(d.getVar('S') + '/deps/uv')
if 'nghttp2' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/deps/nghttp2', True)
+ shutil.rmtree(d.getVar('S') + '/deps/nghttp2')
if 'zlib' in d.getVar('PACKAGECONFIG'):
- shutil.rmtree(d.getVar('S') + '/deps/zlib', True)
+ shutil.rmtree(d.getVar('S') + '/deps/zlib')
}
# V8's JIT infrastructure requires binaries such as mksnapshot and