aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSujith H <Sujith_Haridasan@mentor.com>2014-08-22 11:55:05 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-23 13:20:54 +0200
commitfaf83c51dd4e79419e5dd1abfba96c26a09ac982 (patch)
treea245d3bf053450fae0efc2a908072701f123cd63
parent78038840cccee0464e4d84ba8cfc4d3cec9e369d (diff)
downloadmeta-openembedded-contrib-faf83c51dd4e79419e5dd1abfba96c26a09ac982.tar.gz
python-pyparted: Add recipe
This recipe will provide a set of Python modules that provide Python programmers an interface to libparted, the GNU parted library for disk partitioning and filesystem manipulation. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Sujith H <Sujith_Haridasan@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
new file mode 100644
index 0000000000..919b301db7
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.9.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
+an interface to libparted, the GNU parted library for disk partitioning and \
+filesystem manipulation."
+SUMMARY = "Python bindings for libparted"
+HOMEPAGE = "https://fedorahosted.org/pyparted/"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "\
+ file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://src/_pedmodule.c;startline=10;endline=22;md5=70c62bd73782a03f56a0571a9f08ea46 \
+"
+DEPENDS += "parted"
+
+SRC_URI = "https://fedorahosted.org/releases/p/y/pyparted/pyparted-${PV}.tar.gz"
+SRC_URI[md5sum] = "f16c7ef7f5fa4a43fcb2a4654b487e39"
+SRC_URI[sha256sum] = "a56712e3d058ce3d859c158236dbbf45224018919efd3d880ea80f9e0d0bebbb"
+S = "${WORKDIR}/pyparted-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} += "python-stringold python-codecs python-math"
+BBCLASSEXTEND += "native"