aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-07 15:57:08 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:47:44 -0700
commit362fdac3c2d33e9c80985ec3dd6c308228ee47bd (patch)
tree56d703a0ca7556f8cfb3cfae5cdf55bc1f743002
parent509937ba009a8737ad4245e5aa63a3b398c58dd9 (diff)
downloadmeta-openembedded-contrib-362fdac3c2d33e9c80985ec3dd6c308228ee47bd.tar.gz
libmath-libm-perl: add 1.00
NOTE: No license or copyright information provided. Email address in package is undeliverable. Attempted to contact author at lewart@illinois.edu Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libmath/libmath-libm-perl_1.00.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmath/libmath-libm-perl_1.00.bb b/meta-perl/recipes-perl/libmath/libmath-libm-perl_1.00.bb
new file mode 100644
index 0000000000..83467c40f3
--- /dev/null
+++ b/meta-perl/recipes-perl/libmath/libmath-libm-perl_1.00.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Math::Libm - Perl extension for the C math library, libm"
+DESCRIPTION = "This module is a translation of the C math.h file."
+
+SECTION = "libs"
+
+HOMEPAGE = "https://metacpan.org/pod/Math-Libm"
+
+# Author email Daniel S. Lewart <d-lewart@uiuc.edu> is undeliverable :(
+# Attempted email to lewart@illinois.edu on July 7, 2014
+AUTHOR = "Daniel S. Lewart"
+LICENSE = "No copyright provided (all rights reserved)"
+LIC_FILES_CHKSUM = "file://README;md5=e4ac3d364d7932443c14ec0d78b21ab1"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/D/DS/DSLEWART/Math-Libm-${PV}.tar.gz"
+SRC_URI[md5sum] = "26a4ce8fe507d04c7d40b9eadac428ae"
+SRC_URI[sha256sum] = "bfd309f283ac8cb9bf00af8c7c3a10bf25abfd642861c2022efaff0a4a52c276"
+
+S = "${WORKDIR}/Math-Libm-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " perl-module-strict \
+ perl-module-carp \
+ perl-module-vars \
+ perl-module-exporter \
+ perl-module-dynaloader \
+ perl-module-autoloader \
+"
+
+BBCLASSEXTEND = "native"