aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-03 16:01:57 +0200
committerArmin Kuster <akuster808@gmail.com>2017-08-04 21:07:42 -0700
commit412865c3258913992f6b2a6c302c870ea4dfcbea (patch)
tree164913ec40c995a223494e0413b4dd8cabcd9430
parent35a020bc87028cbb0014895187dddec6dc39321f (diff)
downloadmeta-openembedded-contrib-412865c3258913992f6b2a6c302c870ea4dfcbea.tar.gz
uml-utilities: respect LDFLAGS not only for mconsole but for other binaries as well
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 1214d169f52301bf89b8b15339feb92d84306e2e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
index 05cc5371f7..f4a175cdfd 100644
--- a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -14,3 +14,91 @@
clean :
rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/jailtest/Makefile tools/jailtest/Makefile
+--- tools.orig/jailtest/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/jailtest/Makefile 2017-04-03 16:00:04.857449005 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/moo/Makefile tools/moo/Makefile
+--- tools.orig/moo/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/moo/Makefile 2017-04-03 15:59:56.466449432 +0200
+@@ -10,10 +10,10 @@
+ all : $(BIN)
+
+ uml_moo : $(uml_moo_OBJS)
+- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
++ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
+
+ uml_mkcow : $(uml_mkcow_OBJS)
+- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
++ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
+
+ $(uml_moo_OBJS) $(uml_mkcow_OBJS) : cow.h cow_sys.h
+
+diff -uNr tools.orig/port-helper/Makefile tools/port-helper/Makefile
+--- tools.orig/port-helper/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/port-helper/Makefile 2017-04-03 15:59:41.251450208 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/tunctl/Makefile tools/tunctl/Makefile
+--- tools.orig/tunctl/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/tunctl/Makefile 2017-04-03 16:00:01.091449197 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/uml_net/Makefile tools/uml_net/Makefile
+--- tools.orig/uml_net/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/uml_net/Makefile 2017-04-03 16:00:12.449448618 +0200
+@@ -14,7 +14,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/uml_router/Makefile tools/uml_router/Makefile
+--- tools.orig/uml_router/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/uml_router/Makefile 2017-04-03 16:00:46.796446867 +0200
+@@ -13,7 +13,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/watchdog/Makefile tools/watchdog/Makefile
+--- tools.orig/watchdog/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/watchdog/Makefile 2017-04-03 15:59:45.216450006 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~