aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-02-05 23:46:19 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-11 13:31:08 -0800
commitdbe51dce6e623f86227f0a56144cd075e51a1a01 (patch)
tree7df66c5f2ca4f4dcc3703c4c0fb993081680c088
parent427651e58f470d135207276ab95319bf041d6e83 (diff)
downloadmeta-openembedded-contrib-dbe51dce6e623f86227f0a56144cd075e51a1a01.tar.gz
libyui-ncurses: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch59
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb4
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch
new file mode 100644
index 0000000000..ae1b265dc1
--- /dev/null
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-src-Replace-using-sys-errno.h-with-errno.h.patch
@@ -0,0 +1,59 @@
+From 46f016c4b87bb2a594df1c84e4d494bff0cbeaf9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 5 Feb 2018 12:01:25 -0800
+Subject: [PATCH] src: Replace using sys/errno.h with errno.h
+
+sys/errno.h is no longer the right place for this file
+
+error: #warning redirecting incorrect #include <sys/errno.h> to <errno.h> [-Werror=cpp]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/63]
+ src/NCAskForDirectory.cc | 2 +-
+ src/NCAskForFile.cc | 2 +-
+ src/NCFileSelection.h | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/NCAskForDirectory.cc b/src/NCAskForDirectory.cc
+index 06ec6ac..ed1a30c 100644
+--- a/src/NCAskForDirectory.cc
++++ b/src/NCAskForDirectory.cc
+@@ -39,7 +39,7 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <dirent.h>
+-#include <sys/errno.h>
++#include <errno.h>
+
+ /*
+ Textdomain "ncurses"
+diff --git a/src/NCAskForFile.cc b/src/NCAskForFile.cc
+index 31fdb39..63a6679 100644
+--- a/src/NCAskForFile.cc
++++ b/src/NCAskForFile.cc
+@@ -39,7 +39,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
+-#include <sys/errno.h>
++#include <errno.h>
+
+ /*
+ Textdomain "ncurses"
+diff --git a/src/NCFileSelection.h b/src/NCFileSelection.h
+index d42311f..514d020 100644
+--- a/src/NCFileSelection.h
++++ b/src/NCFileSelection.h
+@@ -38,7 +38,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
+-#include <sys/errno.h>
++#include <errno.h>
+
+
+ struct NCFileInfo
+--
+2.16.1
+
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
index e445ee0ccd..3388876e4f 100644
--- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
+++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
@@ -4,7 +4,9 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
"
-SRC_URI = "git://github.com/libyui/libyui-ncurses.git"
+SRC_URI = "git://github.com/libyui/libyui-ncurses.git \
+ file://0001-src-Replace-using-sys-errno.h-with-errno.h.patch \
+ "
SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch"