aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2018-01-26 22:05:38 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-11 12:01:54 -0800
commit8be761f00743ee7720dad72106bdbe1d2bd2d620 (patch)
tree1d005c9e58848700804794223685720bf18ede40
parentef3aeac19d1e4433d38780a3ef139e350d95ea77 (diff)
downloadmeta-openembedded-contrib-8be761f00743ee7720dad72106bdbe1d2bd2d620.tar.gz
samba: Add packagegroup
Add packagegroup for samba, for there are too many rpms in samba and it's hard to manage. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.7.0.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
index 686998e5ef..08c5882ddf 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
@@ -197,7 +197,7 @@ PACKAGES =+ "${PN}-python ${PN}-pidl \
${PN}-dsdb-modules ${PN}-testsuite registry-tools \
winbind \
${PN}-common ${PN}-base ${PN}-ad-dc ${PN}-ctdb-tests \
- smbclient"
+ smbclient ${PN}-client ${PN}-server ${PN}-test"
python samba_populate_packages() {
def module_hook(file, pkg, pattern, format, basename):
@@ -294,3 +294,27 @@ FILES_smbclient = "${bindir}/cifsdd \
RDEPENDS_${PN}-pidl_append = " perl"
FILES_${PN}-pidl = "${bindir}/pidl ${datadir}/perl5/Parse"
+
+RDEPENDS_${PN}-client = "\
+ smbclient \
+ winbind \
+ registry-tools \
+ ${PN}-pidl \
+ "
+
+ALLOW_EMPTY_${PN}-client = "1"
+
+RDEPENDS_${PN}-server = "\
+ ${PN} \
+ winbind \
+ registry-tools \
+ "
+
+ALLOW_EMPTY_${PN}-server = "1"
+
+RDEPENDS_${PN}-test = "\
+ ${PN}-ctdb-tests \
+ ${PN}-testsuite \
+ "
+
+ALLOW_EMPTY_${PN}-test = "1"