aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-02-10 09:11:48 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-11 13:40:03 -0800
commit740bc7547b565594653dc63c80385271d42d87ef (patch)
tree1264b7c7170317ef3ff2f04b114d0967b8051c76
parent6e833257b3bb702a9f64a0e4ad3f7868fa3896d8 (diff)
downloadmeta-openembedded-contrib-740bc7547b565594653dc63c80385271d42d87ef.tar.gz
python-smbus: remove sed to replace i2c path
The i2c-dev file is now installed in the standard location, so the sed to change the path can be removed. Add a PR value to ensure that if the sed already ran, the build can succeed. Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-smbus.inc7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-smbus.inc b/meta-python/recipes-devtools/python/python-smbus.inc
index 0bca58f1f2..f472a57f43 100644
--- a/meta-python/recipes-devtools/python/python-smbus.inc
+++ b/meta-python/recipes-devtools/python/python-smbus.inc
@@ -1,6 +1,7 @@
SUMMARY = "Set of i2c tools for linux - Python module"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz "
SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa"
@@ -9,9 +10,3 @@ SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f07
DEPENDS += "i2c-tools"
S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
-
-do_configure_prepend() {
- # Adjust for OE header rename
- sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
- sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
-}