aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Tiemann <rtie@gmx.de>2018-11-08 08:38:18 +0100
committerArmin Kuster <akuster808@gmail.com>2018-11-15 13:18:51 -0800
commit9acda33c6975307833ffa2a89656411444041cb1 (patch)
tree0fdcf88a543f104ba242902e676f0ef14ae6eb71
parent5d2151d3b98f8c9fb30be209ec9cea73eac7c854 (diff)
downloadmeta-openembedded-contrib-9acda33c6975307833ffa2a89656411444041cb1.tar.gz
curlpp: Fix packaging and reference to license
This patch fixes three issues: 1. The recipe used "libcurlpp" for its package base name. It defined PACKAGES and corresponding package contents manually, but the non-standard naming led to an error message when trying to depend on it (nothing provides curlpp needed by curlpp-dev). See also https://lists.yoctoproject.org/pipermail/poky/2018-February/011236.html. Fixed by removing PACKAGES and corresponding FILES_*, relying on automatic packaging now. 2. Upstream ships a license file (MIT), which is referenced by the recipe now (instead of the stock COPYING.MIT file). 3. There was a do_install_append() function which patched the installed curlpp.pc file. Since it seemed to be of no use, it was removed. Signed-off-by: Robert Tiemann <rtie@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 340f57dc7e..799cf8611c 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -2,7 +2,7 @@ SUMMARY = "C++ library for client-side URL transfers"
HOMEPAGE = "http://www.curlpp.org/"
SECTION = "libdevel"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=fd0c9adf285a69aa3b4faf34384e1029"
DEPENDS = "curl"
DEPENDS_class-native = "curl-native"
@@ -15,19 +15,4 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig binconfig
-do_install_append () {
- sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
-}
-
-PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
-
-FILES_lib${BPN} = "${libdir}/lib*.so.*"
-
-FILES_lib${BPN}-dev = "${includedir} \
- ${libdir}/pkgconfig \
- ${bindir}/*-config \
-"
-
-FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
-
BBCLASSEXTEND = "native nativesdk"