aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-09-07 18:58:52 +0000
committerArmin Kuster <akuster808@gmail.com>2018-09-09 16:21:36 -0700
commit7fbbbead470e35649305d9372887f84850d2135d (patch)
tree6c031d8a27f6dcad1fb14442eb65effed37f07e8
parentb3fffe67e0ac2a8ab2106d0ecf4ea00dd8b88502 (diff)
downloadmeta-openembedded-contrib-7fbbbead470e35649305d9372887f84850d2135d.tar.gz
openocd: prevent fetching git submodules during do_configure
* I've tried just disabling them with: --disable-internal-jimtcl --disable-internal-libjaylink but that still tries to use missing jim.h: | ./src/helper/jim-nvp.h:47:10: fatal error: jim.h: No such file or directory | #include <jim.h> | ^~~~~~~ | compilation terminated. | Makefile:3619: recipe for target 'src/libopenocd_la-openocd.lo' failed | make[2]: *** [src/libopenocd_la-openocd.lo] Error 1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/openocd/openocd_git.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 20bc663f98..1a15e53b8f 100644
--- a/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -4,14 +4,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libusb-compat libftdi"
RDEPENDS_${PN} = "libusb1"
-SRC_URI = "git://repo.or.cz/openocd.git \
- file://0001-Add-fallthrough-comments.patch \
- file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
- file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
- file://0004-Fix-overflow-warning.patch \
- file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
+SRC_URI = " \
+ git://repo.or.cz/openocd.git;protocol=http;name=openocd \
+ git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
+ git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
+ git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
+ file://0001-Add-fallthrough-comments.patch \
+ file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
+ file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
+ file://0004-Fix-overflow-warning.patch \
+ file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
"
-SRCREV = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_FORMAT = "openocd"
+SRCREV_openocd = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
+SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
+SRCREV_libjaylink = "699b7001d34a79c8e7064503dde1bede786fd7f0"
PV = "0.10+gitr${SRCPV}"
S = "${WORKDIR}/git"
@@ -20,10 +28,10 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
-EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
do_configure() {
- ./bootstrap
+ ./bootstrap nosubmodule
oe_runconf ${EXTRA_OECONF}
}