aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-27 14:14:54 -0700
committerArmin Kuster <akuster808@gmail.com>2018-09-05 08:29:39 -0700
commitd23612ff10eb6f43cd8e13d4c03fe8d9d38898fd (patch)
tree924b21b1f25bb0a45639cbe3ccf5b4a142c885b1
parent3e615d62eb4e11a1e4aa47a980e0fb4130f51e65 (diff)
downloadmeta-openembedded-contrib-d23612ff10eb6f43cd8e13d4c03fe8d9d38898fd.tar.gz
python-evdev: Use target header to generate ecodes.c
ecodes.c is generated file and if we do not specify the linux input headers it happiliy defaults to /usr/include/ to look for these headers while emitting code for ecodes.c which can cause gripes when build systems kernel UAPI is different than the target kernel. Mysterious build errors or even worse runtime errors can start to appear. e.g. | evdev/ecodes.c:603:29: error: 'KEY_ROTATE_LOCK_TOGGLE' undeclared (first use in this function); did you mean 'KEY_ATTENDANT_TOGGLE'? Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> [Handel applied for rocko context] Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-evdev_0.7.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
index 0875da45c3..0940b0057b 100644
--- a/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-evdev_0.7.0.bb
@@ -6,6 +6,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=18debddbb3f52c661a129724a883a8e2"
SRC_URI[md5sum] = "c7e855ae9f97f869a59e75b29f05ce74"
SRC_URI[sha256sum] = "57edafc469a414f58b51af1bfb9ee2babb9f626dd2df530d71c1176871850aa1"
+do_compile_prepend() {
+ rm -rf ${S}/evdev/ecodes.c
+}
+
+DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
+
+
inherit pypi setuptools
RDEPENDS_${PN} += "\