aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-04 13:28:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 01:52:57 +0100
commitf425163e53bd159d2b92631e67eaac9c5660715a (patch)
tree75ed6a0eec9bfd2f45f4f20a635202b310e696ec
parent40877249e305d0788ca7d1bd79c308e5d0a45bad (diff)
downloadmeta-openembedded-contrib-f425163e53bd159d2b92631e67eaac9c5660715a.tar.gz
python-twisted: fix packaging QA warnings
* package topfiles and egg-info in PN-core * fix find call (without braces it removes only last match -name ".h") and _epoll.c, _initgroups.c are left in image * fixes python-twisted-10.2.0: python-twisted: Files/directories were installed but not shipped /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/top_level.txt /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/dependency_links.txt /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/requires.txt /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/SOURCES.txt /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/PKG-INFO /usr/lib/python2.7/site-packages/Twisted-10.2.0-py2.7.egg-info/not-zip-safe /usr/lib/python2.7/site-packages/twisted/topfiles /usr/lib/python2.7/site-packages/twisted/python/_epoll.c /usr/lib/python2.7/site-packages/twisted/python/_initgroups.c /usr/lib/python2.7/site-packages/twisted/topfiles/NEWS /usr/lib/python2.7/site-packages/twisted/topfiles/README /usr/lib/python2.7/site-packages/twisted/topfiles/ChangeLog.Old /usr/lib/python2.7/site-packages/twisted/topfiles/CREDITS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb b/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
index 1455982bbe..5215dd6919 100644
--- a/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
+++ b/meta-oe/recipes-devtools/python/python-twisted_10.2.0.bb
@@ -7,7 +7,7 @@ SECTION = "console/network"
#twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c3159ad36d96a939fcd8f2c2c9b9d08a"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/10.2/Twisted-${PV}.tar.bz2 "
SRC_URI[md5sum] = "73da62c793269eade8121da336b01ba5"
@@ -19,7 +19,7 @@ inherit setuptools
do_install_append() {
# remove some useless files before packaging
- find ${D} -name "*.bat" -o -name "*.c" -o -name "*.h" -exec rm {} \;
+ find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \;
}
PACKAGES += "\
@@ -167,6 +167,8 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \
+${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \
"
FILES_${PN}-lore = " \