aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-22 11:05:25 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-22 12:59:38 -0800
commit3f5223da8ba5f79890f8dd4c162f260401fdc052 (patch)
treedbc558741d5b2b44255045753fe6b086fa1de4dd
parent343338e95565c2a3e2b1e8fbc4fce325ca0ea2f8 (diff)
downloadmeta-openembedded-contrib-3f5223da8ba5f79890f8dd4c162f260401fdc052.tar.gz
python3-ordered-set: Use automake formatter for ptest output
Move the test to PTESTS_FAST_META_PYTHON Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb1
3 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 790d5b019d..6903157cec 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -29,6 +29,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-jsmin \
python3-msgpack \
python3-multidict \
+ python3-ordered-set \
python3-parse \
python3-parse-type \
python3-platformdirs \
@@ -76,7 +77,6 @@ PTESTS_PROBLEMS_META_PYTHON ="\
python3-dnspython \
python3-fastjsonschema \
python3-gpiod \
- python3-ordered-set \
python3-pillow \
python3-pint \
python3-pyzmq \
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
index c27a6c3c57..64799ba008 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest test_ordered_set.py
+pytest --automake test_ordered_set.py
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
index a391036a73..64637b858d 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
@@ -15,6 +15,7 @@ SRC_URI += " \
RDEPENDS:${PN}-ptest += " \
python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {