aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:42 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:38 -0800
commit848765aba678cd675ecd88413d622c8cb8a1d295 (patch)
treecbcfb84140249c3f8ce31147b3b77b7001a1cb2c
parenta62b699bcb5007fbda40ac39bd5c29f1c2a73512 (diff)
downloadmeta-openembedded-contrib-848765aba678cd675ecd88413d622c8cb8a1d295.tar.gz
python3-platformdirs: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 * Sort RDEPENDS for ptest alphabetically Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-platformdirs/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-platformdirs_4.2.0.bb13
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_4.2.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_4.2.0.bb
index ea25f878cc..19c95b374a 100644
--- a/meta-python/recipes-devtools/python/python3-platformdirs_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-platformdirs_4.2.0.bb
@@ -12,15 +12,16 @@ SRC_URI[sha256sum] = "ef0cc731df711022c174543cb70a9b5bd22e5a9337c8624ef2c2ceb8dd
inherit pypi python_hatchling ptest
DEPENDS += " \
- ${PYTHON_PN}-hatch-vcs-native \
+ python3-hatch-vcs-native \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-appdirs \
- ${PYTHON_PN}-covdefaults \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytest-mock \
- ${PYTHON_PN}-pytest-cov \
+ python3-appdirs \
+ python3-covdefaults \
+ python3-pytest \
+ python3-pytest-cov \
+ python3-pytest-mock \
+ python3-unittest-automake-output \
"
do_install_ptest() {