aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2024-02-17 17:34:08 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-17 10:26:58 -0800
commit528f273006965496ce7e19147f0a0e34a97a8f9c (patch)
tree93177524df53530dfa97127a9fb5ae6bd799a4f1
parent5fdbe368875b00980f5975c4f775063033d03243 (diff)
downloadmeta-openembedded-contrib-528f273006965496ce7e19147f0a0e34a97a8f9c.tar.gz
libtinyxml2: allow to build both shared and static libraries
E.g. if we want to build uuu statically, libtinyxml2 static library is missing as it builds only the shared library by default. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb
index 5039e9ff77..1c94eff246 100644
--- a/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb
+++ b/meta-oe/recipes-support/libtinyxml2/libtinyxml2_10.0.0.bb
@@ -12,7 +12,10 @@ S = "${WORKDIR}/git"
inherit meson ptest
-EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}"
+EXTRA_OEMESON += " \
+ ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)} \
+ -Ddefault_library=both \
+"
CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"