aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-02-18 15:54:06 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-18 07:16:29 -0800
commit2bbdb9c22db5e7c68561582bb75f4e70ec1b39bb (patch)
treedf47ea5c41f709cfcf736717d06f057003b9908e
parent5a0fdf9af24fa1a9a96f8575a0dc4159fd546d18 (diff)
downloadmeta-openembedded-contrib-2bbdb9c22db5e7c68561582bb75f4e70ec1b39bb.tar.gz
python3-httpx: respect libdir in packaging
* hardcoding /usr/lib is always wrong, doesn't match with libdir e.g. for multilib causing: ERROR: QA Issue: python3-httpx: Files/directories were installed but not shipped in any package: /usr/lib64 /usr/lib64/python3.12 /usr/lib64/python3.12/site-packages /usr/lib64/python3.12/site-packages/httpx ... /usr/lib64/python3.12/site-packages/httpx/__pycache__/__version__.cpython-312.pyc /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/entry_points.txt /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/WHEEL /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/METADATA /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/RECORD /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/licenses /usr/lib64/python3.12/site-packages/httpx-0.26.0.dist-info/licenses/LICENSE.md Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. python3-httpx: 63 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb b/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb
index 9abd13e2be..50bff7f851 100644
--- a/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb
+++ b/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb
@@ -36,9 +36,9 @@ RDEPENDS:${PN}-cli += "\
"
FILES:${PN} = "\
- /usr/lib/python${PYTHON_BASEVERSION} \
+ ${libdir}/${PYTHON_DIR} \
"
FILES:${PN}-cli = "\
- /usr/bin/httpx \
+ ${bindir}/httpx \
"