aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-07-02 16:16:18 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commitcd0ecef266549cba02244ad8cf4b3d18e9612e21 (patch)
treeeacabdc90f9145fe634bdedd916dbb7c96030236
parentf818d3b9fc11a067a5144279a8dce8f4ef07e334 (diff)
downloadmeta-openembedded-contrib-cd0ecef266549cba02244ad8cf4b3d18e9612e21.tar.gz
libbytesize: 1.4 -> 2.0
- Depends on libpcre2 since upstream commit [1c7e40a Port to pcre2] - Remove PACKAGECONFIG python2 since upstream commit [895baa3 Remove Python 2 support] - Fix out of tree build failure - RDEPENDS on python3-core rather than python3 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libbytesize/files/0001-fix-out-of-tree-build-failure.patch37
-rw-r--r--meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb (renamed from meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb)8
2 files changed, 41 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/libbytesize/files/0001-fix-out-of-tree-build-failure.patch b/meta-oe/recipes-support/libbytesize/files/0001-fix-out-of-tree-build-failure.patch
new file mode 100644
index 0000000000..3f42c25d7e
--- /dev/null
+++ b/meta-oe/recipes-support/libbytesize/files/0001-fix-out-of-tree-build-failure.patch
@@ -0,0 +1,37 @@
+From 55802fd187b844f0c114c1657b18482bfc80ec51 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 2 Jul 2019 02:52:31 +0000
+Subject: [PATCH] fix out of tree build failure
+
+Since commit [116da95 Add the '--version' option to bs_calc.py] applied,
+while build out of tree, there is a install failure
+...
+|install -m0755 ../../git/tools/bs_calc.py /usr/bin/bscalc
+|install: cannot stat '../../git/tools/bs_calc.py': No such file or directory
+...
+
+The generated bs_calc.py locates in builddir rather than srcdir
+
+Upstream-Status: Submitted [https://github.com/storaged-project/libbytesize/pull/59]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ tools/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 08223a8..ae22fed 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -5,7 +5,7 @@ dist_man1_MANS = bscalc.man
+
+ install-exec-local:
+ install -d ${DESTDIR}${bindir}
+- install -m0755 ${srcdir}/bs_calc.py ${DESTDIR}${bindir}/bscalc
++ install -m0755 ${builddir}/bs_calc.py ${DESTDIR}${bindir}/bscalc
+
+ uninstall-local:
+ rm ${DESTDIR}${bindir}/bscalc
+--
+2.17.1
+
diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb b/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb
index 863ce428f1..1beb6777ea 100644
--- a/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb
@@ -9,14 +9,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
S = "${WORKDIR}/git"
B = "${S}"
-SRCREV = "ebbda2217d177d2a17f917d7a3e3d132a26db791"
+SRCREV = "92c00638a6f846df5c40dbb690f9fcf998ad6df2"
SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
+ file://0001-fix-out-of-tree-build-failure.patch \
"
inherit gettext autotools python3native
DEPENDS += " \
- libpcre \
+ libpcre2 \
gmp \
mpfr \
"
@@ -24,8 +25,7 @@ DEPENDS += " \
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
PACKAGECONFIG ??= "python3"
-PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
-PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"