aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@gmail.com>2018-05-10 09:12:24 +1000
committerArmin Kuster <akuster808@gmail.com>2018-06-14 19:58:51 -0700
commit734513d8b31cd68da01db1cf880788c190ae6457 (patch)
treec7d7cdcc32984f013141a6778c3d558fba8dec9f
parent31cdab6e1ef36fd172e2b3ffd5d20bcff38d3094 (diff)
downloadmeta-openembedded-contrib-734513d8b31cd68da01db1cf880788c190ae6457.tar.gz
python-robotframework: Add runtime dependencies to robot framework
Add the runtime dependencies robot framework has so they are available on images including it. python-robotframework.inc is included by both python3 and python robot framework. python3 includes zlib by default so include python-zlib as a runtime dependency in the python-robotframework recipe and not in the python3-robotframework. Signed-off-by: Sipke Vriend <sipke.vriend@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit f90318b625a90993c4e20c981201602e37f89481) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb4
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-robotframework.inc b/meta-python/recipes-devtools/python/python-robotframework.inc
index cc20d6477b..78bbbc6de0 100644
--- a/meta-python/recipes-devtools/python/python-robotframework.inc
+++ b/meta-python/recipes-devtools/python/python-robotframework.inc
@@ -13,3 +13,14 @@ inherit pypi
SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa"
SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-ctypes \
+"
diff --git a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
index 16eaa78cdb..ff7dedb559 100644
--- a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-robotframework.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-zlib \
+"