aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2017-11-16 19:05:53 +0100
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commit73ac0e419a6c78dfc68a34a0675c525bc6f01271 (patch)
tree25ff92c805af56ff6620384f55bcbd3b50fba48c
parenta700bb554f26e04ab340f8942f4c212b3602f1a3 (diff)
downloadmeta-openembedded-contrib-73ac0e419a6c78dfc68a34a0675c525bc6f01271.tar.gz
hiredis: fix paths in pkgconfig conf file
Set PREFIX via EXTRA_OEMAKE instead of exporting it in do_install_prepend(): than ensuring the correct prefix gets into hiredis.pc, which is generated by upstream makefile at do_compile() time. Signed-off-by: Andrea Galbusera <gizero@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/hiredis/hiredis_0.13.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/hiredis/hiredis_0.13.1.bb b/meta-oe/recipes-extended/hiredis/hiredis_0.13.1.bb
index 96b86f9a0c..fae30d771d 100644
--- a/meta-oe/recipes-extended/hiredis/hiredis_0.13.1.bb
+++ b/meta-oe/recipes-extended/hiredis/hiredis_0.13.1.bb
@@ -12,10 +12,11 @@ S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig
+EXTRA_OEMAKE = "PREFIX=${prefix}"
+
# By default INSTALL variable in Makefile is equal to 'cp -a', which preserves
# ownership and causes host-user-contamination QA issue.
# And PREFIX defaults to /usr/local.
do_install_prepend() {
- export PREFIX=${prefix}
export INSTALL='cp -r'
}