aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-10 21:54:21 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:32 +0200
commit592e9f26cca4944adf4e534af5794680f07d098c (patch)
tree5f9d1986504dc7a901f9e30787db030e1856b1bd
parent2563210d055ef261d6443472daeacf21f16253a2 (diff)
downloadmeta-openembedded-contrib-592e9f26cca4944adf4e534af5794680f07d098c.tar.gz
libdbus-c++: Add -pthread to linker flags
It uses symbols from libpthread e.g. pthread_mutexattr_init and pthread_mutexattr_settype but does not link with pthreads, gold is strict about it and calls out with an error ../src/.libs/libdbus-c++-1.so: error: undefined reference to 'pthread_mutexattr_init' ../src/.libs/libdbus-c++-1.so: error: undefined reference to 'pthread_mutexattr_settype' Therefore correct the linker cmdline Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
index 4cc133301d..a6d8b86ee0 100644
--- a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
+++ b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
@@ -21,6 +21,7 @@ SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385
inherit autotools pkgconfig
EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
+LDFLAGS += "-pthread"
PACKAGE_BEFORE_PN = "${PN}-tools"