aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Luebbe <jlu@pengutronix.de>2019-11-21 13:09:13 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-22 09:22:56 -0800
commit8cff2b64b44e14d065121aab36bf23f9eac001c1 (patch)
treef31a00eb03c27abb26e17a643c131f04f508c2ff
parent8d90acd59d4eef5f171be8a0cd36b8df95cacd07 (diff)
downloadmeta-openembedded-contrib-8cff2b64b44e14d065121aab36bf23f9eac001c1.tar.gz
softhsm: add recipe
This is useful for consolidation of code-signing interfaces when building an image with verified boot mechanisms or signed update artifacts. It can also be used on the target as a backend for software which uses the PKCS#11 API to access private key material. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/softhsm/softhsm_git.bb b/meta-oe/recipes-security/softhsm/softhsm_git.bb
new file mode 100644
index 0000000000..3236cb9a60
--- /dev/null
+++ b/meta-oe/recipes-security/softhsm/softhsm_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "PKCS#11 HSM/Token Emulator"
+HOMEPAGE = "https://www.opendnssec.org/softhsm/"
+LICENSE = "BSD-2-Clause & ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
+DEPENDS = "openssl"
+PV = "2.5.0"
+
+SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master"
+SRCREV = "369df0383d101bc8952692c2a368ac8bc887d1b4"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+# EdDSA requires OpenSSL >= 1.1.1
+EXTRA_OECONF = "--enable-eddsa --disable-gost"
+
+BBCLASSEXTEND = "native"