aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-19 23:33:55 -0800
committerRobert Yang <liezhi.yang@windriver.com>2015-11-20 01:35:50 -0800
commitf3454647898cfda69231e31aec1b8b4b684d801b (patch)
tree49bff86f16c0ed9c770a1d0ea52c95c4a6c30196
parentea319464b673cbf9a416b582dc4766faeb998430 (diff)
downloadmeta-openembedded-contrib-f3454647898cfda69231e31aec1b8b4b684d801b.tar.gz
lldpad: fix installed-vs-shipped
Fixed when multilib: lldpad-0.9.46: lldpad: Files/directories were installed but not shipped in any package: /usr/lib Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. lldpad: 1 installed and not shipped files. [installed-vs-shipped] This is because /usr/lib/systemd has been moved, but /usr/lib was left in multilib, use "rmdir -p" to fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
index b191df59e3..b66344f08c 100644
--- a/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
+++ b/meta-networking/recipes-daemons/lldpad/lldpad_0.9.46.bb
@@ -23,7 +23,7 @@ do_configure_prepend() {
do_install_append () {
install -m 0755 -d ${D}${systemd_unitdir}
mv ${D}${prefix}${systemd_unitdir}/* ${D}${systemd_unitdir}/
- rmdir ${D}${prefix}${systemd_unitdir}
+ rmdir -p --ignore-fail-on-non-empty ${D}${prefix}${systemd_unitdir}
}
FILES_${PN} += "${systemd_unitdir}"