aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2014-12-03 12:09:55 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-09 11:37:05 +0100
commite9dd4ceaa3da940f238afca1abf397db1ea80681 (patch)
treeca1a168c1a49088b36351c31e5b1dbb3073375ec
parent79a46c15ae7ff2390d923d008c120e119ebb0489 (diff)
downloadmeta-openembedded-contrib-e9dd4ceaa3da940f238afca1abf397db1ea80681.tar.gz
haveged: Add recipe for haveged entropy daemon v1.9.1
As we are building software for headless embedded devices, we don't want to rely on the entropy generated by default linux kernel mechanisms. Haveged seems to be a good solution in providing more entropy for headless devices. Upstream-Status: Pending Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/haveged/haveged/remove-systemd-unit-503.patch20
-rw-r--r--meta-oe/recipes-extended/haveged/haveged_1.9.1.bb32
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/haveged/haveged/remove-systemd-unit-503.patch b/meta-oe/recipes-extended/haveged/haveged/remove-systemd-unit-503.patch
new file mode 100644
index 0000000000..df27bcb091
--- /dev/null
+++ b/meta-oe/recipes-extended/haveged/haveged/remove-systemd-unit-503.patch
@@ -0,0 +1,20 @@
+--- a/init.d/Makefile.am 2014-01-02 18:55:53.000000000 +0100
++++ b/init.d/Makefile.am 2014-08-11 10:59:40.000000000 +0200
+@@ -34,11 +34,11 @@
+ $(do_subst) < $(srcdir)/$(src_tmpl) > haveged.service;
+
+ install-data-hook:
+-if ENABLE_SYSTEMD_LOOKUP
+- install -p -m644 haveged.service `pkg-config --variable=systemdsystemunitdir systemd`/haveged.service;
+-else
+- install -p -m644 haveged.service ($unit_dir)/haveged.service;
+-endif
+- systemctl enable haveged.service;
++#if ENABLE_SYSTEMD_LOOKUP
++# install -p -m644 haveged.service `pkg-config --variable=systemdsystemunitdir systemd`/haveged.service;
++#else
++# install -p -m644 haveged.service ($unit_dir)/haveged.service;
++#endif
++# systemctl enable haveged.service;
+
+ endif
diff --git a/meta-oe/recipes-extended/haveged/haveged_1.9.1.bb b/meta-oe/recipes-extended/haveged/haveged_1.9.1.bb
new file mode 100644
index 0000000000..fbd1992d63
--- /dev/null
+++ b/meta-oe/recipes-extended/haveged/haveged_1.9.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "haveged - A simple entropy daemon"
+DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
+AUTHOR = "Gary Wuertz"
+HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://www.issihosts.com/haveged/haveged-${PV}.tar.gz \
+ file://remove-systemd-unit-503.patch \
+ "
+
+SRC_URI[md5sum] = "015ff58cd10607db0e0de60aeca2f5f8"
+SRC_URI[sha256sum] = "9c2363ed9542a6784ff08e247182137e71f2ddb79e8e6c1ac4ad50d21ced3715"
+
+PR = "r0"
+
+inherit autotools systemd
+
+EXTRA_OECONF = "\
+ --enable-init=service.redhat \
+ --enable-nistest=yes \
+ --enable-olt=yes \
+ --enable-threads=no \
+ "
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "haveged.service"
+
+do_install_append() {
+ mkdir -p ${D}${systemd_unitdir}/system
+ install -p -m644 ${B}/init.d/haveged.service ${D}${systemd_unitdir}/system
+}