aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2014-12-01 15:32:44 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-09 11:37:05 +0100
commit5413dbaf5421b4d848b669b8e07da02f0e877c63 (patch)
tree207b13bef29d154e1c0305bc87606a71e1dbefc1
parentb2b8c7b93e16668f5cd3e87816de8fc73078e46a (diff)
downloadmeta-openembedded-contrib-5413dbaf5421b4d848b669b8e07da02f0e877c63.tar.gz
libnet-ssleay-perl: avoid host contamination
Check the configure log, libnet-ssleay-perl uses host's openssl: *** Found OpenSSL-1.0.1 installed in /usr Export OPENSSL_PREFIX to find the native openssl to use. Replace library pathes '/lib', '/usr/lib' and header path with correct staging pathes at same time. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
index 63594b94b2..f6c4b8b36c 100644
--- a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
@@ -28,12 +28,16 @@ S = "${WORKDIR}/Net-SSLeay-${PV}"
inherit cpan ptest
-EXTRA_CPANFLAGS = "LIBS='-L=${libdir} -L=${base_libdir}' \
- INC=-I=${includedir} \
+EXTRA_CPANFLAGS = "LIBS='-L=${STAGING_LIBDIR} -L=${STAGING_BASELIBDIR}' \
+ INC=-I=${STAGING_INCDIR} \
'EXTRALIBS=-lssl -lcrypto -lz' \
'LDLOADLIBS=-lssl -lcrypto -lz' \
"
+do_configure_prepend() {
+ export OPENSSL_PREFIX=${STAGING_DIR_NATIVE}${prefix_native}
+}
+
do_install_ptest() {
cp -r ${B}/t ${D}${PTEST_PATH}
}