aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2014-12-19 10:09:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-31 16:35:34 +0100
commitafbeff6463b6c5df0bf4f27c152af618a8ce321d (patch)
treeed48c3f8a814f172fb838cb757bc12c5e8832dc0
parentaf74f962282c0bf8edd0cebeb2e69865f66b06ea (diff)
downloadmeta-openembedded-contrib-afbeff6463b6c5df0bf4f27c152af618a8ce321d.tar.gz
fwts: add the Firmware Test Suite
The Firmware Test Suite is a set of tests for checking ACPI and EFI implementations for common bugs and issues. Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Graeme Gregory <graeme.gregory@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-test/fwts/fwts_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts_git.bb b/meta-oe/recipes-test/fwts/fwts_git.bb
new file mode 100644
index 0000000000..b943d6d48e
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Firmware testsuite"
+DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
+HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=deb8af5388e838d133eaa036f4d1496f"
+
+PV = "14.12.00"
+
+SRCREV = "efc18d16294f492b7f72bba64344b2eed50e6a69"
+SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libpcre json-c glib-2.0"
+
+inherit autotools-brokensep
+
+CFLAGS += "-I${STAGING_INCDIR}/json-c"
+
+FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
+FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
+FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
+FILES_${PN}-dbg += "${libdir}/fwts/.debug"