aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Pijanowski <maciej.pijanowski@3mdeb.com>2019-10-04 17:38:02 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-04 19:11:55 -0700
commit01d539b324a867a01b271946321f2bfd031c2e67 (patch)
tree0b2e5d9c2a4e3167bd00eb007b63f2897aae370c
parent6e31ebb24a2101477d3fb568374baae0cd8b7b82 (diff)
downloadmeta-openembedded-contrib-01d539b324a867a01b271946321f2bfd031c2e67.tar.gz
smem: package smemcap separately
Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> smemcap is a tiny binary which allows capturing current state of the /proc for further offline analysis. Package it seperately so there is no need to install python runtime dependencies on the embedded system when not required. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/smem/smem_1.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/smem/smem_1.4.bb b/meta-oe/recipes-support/smem/smem_1.4.bb
index 519020f3b0..702217a33d 100644
--- a/meta-oe/recipes-support/smem/smem_1.4.bb
+++ b/meta-oe/recipes-support/smem/smem_1.4.bb
@@ -25,3 +25,7 @@ do_install() {
install -m 0644 ${S}/smem.8 ${D}/${mandir}/man8/
}
RDEPENDS_${PN} += "python-textutils python-compression python-shell python-codecs"
+
+PACKAGES =+ "smemcap"
+
+FILES_smemcap = "${bindir}/smemcap"