aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-10-11 00:34:27 +0200
committerKhem Raj <raj.khem@gmail.com>2019-10-10 21:58:10 -0700
commitd2ba4b2aba792443235a87ebfbdf801c57334e89 (patch)
treede01b73d25c8bd1f5329bf8eafbc25b28aa2ad94
parente7c2b20cd7365c733bb4a5d1da1378cec039024b (diff)
downloadmeta-openembedded-contrib-d2ba4b2aba792443235a87ebfbdf801c57334e89.tar.gz
networkd-dispatcher: use distro_features_check to check for systemd
Use distro_features_check to check for systemd in DISTRO_FEATURES instead of a hand-crafted python function. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
index 008a7ac9a7..c700bd17cc 100644
--- a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.0.1.bb
@@ -1,9 +1,3 @@
-python __anonymous() {
- features = d.getVar('DISTRO_FEATURES')
- if not features or 'systemd' not in features:
- raise bb.parse.SkipPackage('networkd-dispatcher needs systemd in DISTRO_FEATURES')
-}
-
SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
more limited in the types of events it supports due to the limited nature of \
@@ -13,7 +7,10 @@ AUTHOR = "Clayton Craft and others"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+inherit distro_features_check
+
RDEPENDS_${PN} = "systemd python3 python3-pygobject python3-dbus"
+REQUIRED_DISTRO_FEATURES = "systemd"
SRC_URI = "https://gitlab.com/craftyguy/networkd-dispatcher/-/archive/${PV}/networkd-dispatcher-${PV}.tar.bz2"
SRC_URI[md5sum] = "304d7dcc21331ea295e207f8493cb8d8"