aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-01-11 17:41:17 +0100
committerAndreas Oberritter <obi@opendreambox.org>2015-04-22 10:07:57 +0200
commit75e003dc1f7d671c5cbce481948f6ed65435a14f (patch)
tree907d286740c8bf1df9be10c7c8ef2530d6846849
parent3ac081c3652143b2dcc75826f42575e6cf7e57d0 (diff)
downloadmeta-openembedded-contrib-75e003dc1f7d671c5cbce481948f6ed65435a14f.tar.gz
dracut: add git version
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 039b0190d9049768876af892cf9e18324a8d7c63) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch39
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb38
2 files changed, 77 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
new file mode 100644
index 0000000000..7dc62ded76
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
@@ -0,0 +1,39 @@
+From c92ea797c43aa811e98b6bd8fb4aae921fa08592 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 10 Jan 2014 21:11:40 +0100
+Subject: [PATCH] Use builtin xz/lzma option to use all cores for multihreaded
+ compression
+
+This removes the dependency on 'getconf' as well, which is not installed by default on my embedded systems.
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+Upstream-status: Submitted
+
+---
+ dracut.sh | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/dracut.sh b/dracut.sh
+index 11dcd0e..2e6ea67 100755
+--- a/dracut.sh
++++ b/dracut.sh
+@@ -697,14 +697,12 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
+ # eliminate IFS hackery when messing with fw_dir
+ fw_dir=${fw_dir//:/ }
+
+-cpu_count=$(getconf _NPROCESSORS_ONLN)
+-
+ # handle compression options.
+ [[ $compress ]] || compress="gzip"
+ case $compress in
+ bzip2) compress="bzip2 -9";;
+- lzma) compress="lzma -9 ${cpu_count:+-T$cpu_count}";;
+- xz) compress="xz --check=crc32 --lzma2=dict=1MiB ${cpu_count:+-T$cpu_count}";;
++ lzma) compress="lzma -9 -T0";;
++ xz) compress="xz --check=crc32 --lzma2=dict=1MiB -T0";;
+ gzip) compress="gzip -9"; command -v pigz > /dev/null 2>&1 && compress="pigz -9";;
+ lzo) compress="lzop -9";;
+ lz4) compress="lz4 -9";;
+--
+1.8.0
+
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
new file mode 100644
index 0000000000..ccc4e7d6b3
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Initramfs generator using udev"
+DESCRIPTION = "Dracut is an event driven initramfs infrastructure. dracut (the tool) is used to create an initramfs image by copying tools and files from an installed system and combining it with the dracut framework, usually found in /usr/lib/dracut/modules.d."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCREV = "bb1ba3a1ca9dd6284f6319eb197de4a757a7f99d"
+SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git \
+ file://0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ./configure --prefix=${prefix} \
+ --libdir=${libdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sbindir=${sbindir} \
+ --disable-documentation \
+ --bindir=${bindir} \
+ --includedir=${includedir} \
+ --localstatedir=${localstatedir} \
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${datadir}/bash-completion \
+ ${libdir}/kernel \
+ "
+
+RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid bash ldd"
+# This could be optimized a bit, but let's avoid non-booting systems :)
+RRECOMMENDS_${PN} = " \
+ kernel-modules \
+ "