aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormmovchan@cisco.com <mmovchan@cisco.com>2018-01-17 16:30:44 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-19 14:38:11 -0800
commita3d4caa758268b25d0c7c247603bcbf98eb46525 (patch)
tree0f26111a3a38c388c4d0f68b71b1b73c6c22b58e
parent8e8238a9bc399b548936f64100fd37397fd81391 (diff)
downloadmeta-openembedded-contrib-a3d4caa758268b25d0c7c247603bcbf98eb46525.tar.gz
ipcalc: add initial recipe for version 0.2.0
Signed-off-by: Mariia Movchan <mmovchan@cisco.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/ipcalc/ipcalc_0.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ipcalc/ipcalc_0.2.0.bb b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.0.bb
new file mode 100644
index 0000000000..bb283c80b5
--- /dev/null
+++ b/meta-networking/recipes-support/ipcalc/ipcalc_0.2.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Tool to assist in network address calculations for IPv4 and IPv6."
+HOMEPAGE = "https://github.com/nmav/ipcalc"
+
+SECTION = "net"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+SRC_URI = "https://github.com/nmav/ipcalc/archive/${PV}.tar.gz;downloadfilename=ipcalc-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "edbfc4cb64632e0c4f87cf81c7d8302d"
+SRC_URI[sha256sum] = "c965c1296172a6acc50d54dfe81f7e5d589f9762b5d9ae459eee00349675336b"
+
+export USE_GEOIP = "no"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/ipcalc ${D}/${bindir}
+}