aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Wiehler <stefan.wiehler@missinglinkelectronics.com>2019-10-15 08:56:06 +0200
committerArmin Kuster <akuster808@gmail.com>2019-11-24 12:56:29 -0800
commitc53a33030b3ff9172867cb23ff40e2a9694882fe (patch)
tree8bf41bdd32094815c2485aa49f4534194aa4539b
parentdf851c3e35f42b9ec2d2dc216ec7bb5d3a078af9 (diff)
downloadmeta-openembedded-contrib-c53a33030b3ff9172867cb23ff40e2a9694882fe.tar.gz
nvme-cli: defer host ID generation to post installation
Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
index 6133b3a270..92c902b750 100644
--- a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
+++ b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
-DEPENDS = "util-linux util-linux-native"
+DEPENDS = "util-linux"
PV .= "+git${SRCPV}"
SRC_URI = "git://github.com/linux-nvme/nvme-cli.git"
@@ -21,6 +21,7 @@ do_install() {
pkg_postinst_ontarget_${PN}() {
${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
+ ${bindir}/uuidgen > ${sysconfdir}/nvme/hostid
}
PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
@@ -28,3 +29,5 @@ PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
FILES_${PN} += "${systemd_system_unitdir}"
FILES_${PN}-dracut = "${libdir}/dracut/dracut.conf.d"
FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"
+
+RDEPENDS_${PN} = "util-linux-uuidgen"