aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-07-11 13:52:55 +0800
committerArmin Kuster <akuster808@gmail.com>2019-09-02 19:39:07 -0700
commitc73bf450d73e5cc08fd042cb5c98db1631e475bc (patch)
tree684a2c8f30b321832a6e6713a3db53b577ec2880
parent15ca4c94535002a773283c2d084e1f2c91963052 (diff)
downloadmeta-openembedded-contrib-c73bf450d73e5cc08fd042cb5c98db1631e475bc.tar.gz
volume-key: fix "Nothing RPROVIDES" when multilib enabled
Multilib enabled, and add IMAGE_INSTALL_append = " python3-volume-key" in local.conf fix below problem: ERROR: Required build target 'lib32-core-image-minimal' has no buildable providers. Missing or unbuildable dependency chain was: ['lib32-core-image-minimal', 'lib32-python3-volume-key'] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb b/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
index 398ca5c21b..3103748e40 100644
--- a/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
+++ b/meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb
@@ -31,8 +31,7 @@ PACKAGECONFIG ??= "python3"
PACKAGECONFIG[python] = "--with-python,--without-python,python,python"
PACKAGECONFIG[python3] = "--with-python3,--without-python3,python3,python3"
-RDEPENDS_python3-${PN} += "${PN}"
-
-PACKAGES += "python3-${PN}"
-FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+RDEPENDS_python3-${BPN} += "${PN}"
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/*"