aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-04-29 13:53:16 +0200
committerKhem Raj <raj.khem@gmail.com>2024-04-30 11:00:33 -0700
commita64e300c72bd218e71570d1ce53a893231d1a36e (patch)
treef1c05cc567be20bebdac0d040fa7b972b2fb5b7e
parent9fed5812ab2e66993faac1c6be8e9512627e756a (diff)
downloadmeta-openembedded-contrib-a64e300c72bd218e71570d1ce53a893231d1a36e.tar.gz
libgweather: fix build with gobject-introspection 1.80.0
gweather build is running a python script build-aux/meson/gen_locations_variant.py which imports g-i data at build time: from gi.repository import GLib Previously this would import the typelib file installed by native g-i (which would likely not match the cross target, but nvm). New g-i version no longer installs those files, so the options are: - run the python script with target python inside qemu - copy the needed typelib from target sysroot into the native one. I took the easy way out. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
index acf2885281..e0c8724a31 100644
--- a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
@@ -28,3 +28,7 @@ FILES:${PN} += " \
${datadir}/libgweather-4 \
${libdir}/libgweather-4 \
"
+
+do_configure:prepend() {
+ cp -f ${STAGING_LIBDIR}/girepository-1.0/GLib*typelib ${STAGING_LIBDIR_NATIVE}/girepository-1.0/
+}