aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-10-31 17:51:22 -0200
committerArmin Kuster <akuster808@gmail.com>2018-02-01 07:32:05 -0800
commitf80ff75c448668f3c68166fd37ef4c4ebbcbc453 (patch)
tree61df60cea97426cc02d927d3a4b4bea93f929e78
parentb54c14056477db980817c03153ab65ed0510d35c (diff)
downloadmeta-openembedded-contrib-f80ff75c448668f3c68166fd37ef4c4ebbcbc453.tar.gz
arptables: Fix do_install task
We need to run oe_runmake install with DESTDIR variable to install all arptables files. Without this the only file installed in package is systemd unit. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit f122ecd7171b2258452131cc75d809b02a1f4f02) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/arptables/arptables_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_git.bb b/meta-networking/recipes-support/arptables/arptables_git.bb
index 274a55d91d..cec1d1f77e 100644
--- a/meta-networking/recipes-support/arptables/arptables_git.bb
+++ b/meta-networking/recipes-support/arptables/arptables_git.bb
@@ -23,7 +23,8 @@ inherit systemd
EXTRA_OEMAKE = "'BINDIR=${sbindir}' 'MANDIR=${mandir}'"
-do_install_append() {
+do_install() {
+ oe_runmake install DESTDIR=${D}
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/arptables.service ${D}${systemd_unitdir}/system