aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2014-12-15 08:55:47 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:23:00 +0200
commit035a8bd9f42cef006940545af1bfa5d5311171f2 (patch)
treeae586ab5f0207176c859b6f5c8d79a8fb145b4e3
parentaf003c1ed7589299e98bfd9b7f17df5353260b09 (diff)
downloadmeta-openembedded-contrib-035a8bd9f42cef006940545af1bfa5d5311171f2.tar.gz
lib-perl: move package from meta-security to meta-perl
please consider this common package for meta-perl. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libperl/lib-perl_0.63.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libperl/lib-perl_0.63.bb b/meta-perl/recipes-perl/libperl/lib-perl_0.63.bb
new file mode 100644
index 0000000000..7895864be1
--- /dev/null
+++ b/meta-perl/recipes-perl/libperl/lib-perl_0.63.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "This is a small simple module which simplifies the \
+manipulation of @INC at compile time. It is typically used to add extra \
+directories to Perl's search path so that later 'use' or 'require' statements \
+will find modules which are not located in the default search path."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=94b119f1a7b8d611efc89b5d562a1a50"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://www.cpan.org/authors/id/S/SM/SMUELLER/lib-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "8607ac4e0d9d43585ec28312f52df67c"
+SRC_URI[sha256sum] = "72f63db9220098e834d7a38231626bd0c9b802c1ec54a628e2df35f3818e5a00"
+
+S = "${WORKDIR}/lib-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}